Locknet Managed IT Status Page - Barracuda Email Gateway Defense Mailflow is down – Incident details

Barracuda Email Gateway Defense Mailflow is down

Resolved
Major outage
Started about 1 month agoLasted about 2 hours

Affected

Barracuda Email Protection

Major outage from 12:40 PM to 2:13 PM

Updates
  • Resolved
    Resolved

    This incident has been resolved. Barracuda is reporting mail flow is returning to normal levels. If you are still experiencing mail flow issues please engage Locknet Support.

  • Identified
    Identified

    Barracuda has identified an issue impacting mail flow in the US, DE, CA, and AU regions. Barracuda is working to resolve the issue. User interface accessibility may also be affected by this issue.

  • Investigating
    Investigating
    We are currently investigating this incident.